Подключение принтера KYOCERA ECOSYS FS-1060DN в Linux

kyocera fs-1060dn linux driver

Установка драйверов для принтера Kyocera Ecosys FS-1060DN в Linux.

Описание принтера.

Общие характеристики
Тип печати черно-белая
Технология печати лазерная
Размещение настольный
Область применения малый офис, дом
Количество страниц в месяц 20000
Принтер
Максимальный формат A4
Автоматическая двусторонняя печать есть
Максимальное разрешение для ч/б печати 1200×1200 dpi
Скорость печати 25 стр/мин (ч/б А4)
Время разогрева 16 с
Время выхода первого отпечатка 7.50 c (ч/б)
Лотки
Подача бумаги 251 лист (стандартная), 251 лист (максимальная)
Вывод бумаги 150 листов (стандартный), 150 листов (максимальный)
Емкость лотка ручной подачи 1 лист
Расходные материалы
Плотность бумаги 60-220 г/м2
Печать на: карточках, этикетках, глянцевой бумаге, конвертах, матовой бумаге
Ресурс ч/б картриджа/тонера 3000 страниц, в комплекте картридж меньшей емкости
Количество картриджей 1
Тип картриджа/тонера ТК-1120
Память/Процессор
Объем памяти 32 Мб
Процессор ARM
Частота процессора 390 МГц
Интерфейсы
Интерфейсы Ethernet (RJ-45) 1
Интерфейсы USB 2.0 1
Шрифты и языки управления
Поддержка PostScript нет
Дополнительная информация
Поддержка ОС Windows, Mac OS, Linux
Потребляемая мощность (при работе) 346 Вт
Потребляемая мощность (в режиме ожидания) 6 Вт
Уровень шума при работе 49 дБ
Уровень шума в режиме ожидания 29 дБ
Габариты (ШхВхГ) 358x241x276 мм
Вес 6.7 кг

Установка драйверов в Linux.

Если вы приобрели принтер Kyocera FS-1060DN и при этом используете Linux, вам понадобится установить для него драйвера, поскольку они, скорее всего, не идут в комплекте с системой печати CUPS. Это файлы PPD, в которых содержится описание параметров принтера и его возможностей и фильтр для печати, программа, передающая принтеру информацию в понятном для него виде. Драйвера присутствуют на диске, входящем в комплект принтера, в виде файлов tar.gz. Однако это не самый удобный способ установки. Поэтому я собрал инсталлятор для Linux.

Вот как выглядит установка при его использовании:

Для установки потребуются права пользователя root, чтобы скопировать файлы в системные директории. Поэтому вам может понадобиться использовать команду «sudo».

В инсталлятор включены драйвера для следующих устройств:
— Kyocera FS-1020MFP
— Kyocera FS-1025MFP
— Kyocera FS-1040
— Kyocera FS-1060DN
— Kyocera FS-1120MFP
— Kyocera FS-1125MFP

После установки драйверов можно подключать принтер через CUPS. Как это сделать можно прочитать здесь.

Если есть какие-то вопросы и замечания, пишите. Контакты здесь.

P.S.: У инсталлятора есть Git-репозиторий, буду рад коммитам. Адрес: https://github.com/mnorin/kyocera-ppd-installer

Подключение принтера KYOCERA ECOSYS FS-1060DN в Linux: 55 комментариев

  1. Сергей

    Провозился с кеосерой 1020, с капса печатает с нужной мне программы нет, говорить печать остановлено, поставил ваш драйвер и БИНГО!!! Заработало! Спасибо!

  2. Роман

    Большое спасибо за ваш драйвер. До этого брал драйвер с официального сайта и не смог вылечить ошибку «FIlter failed». А ваш драйвер заработал.

  3. Иван

    Всё сделал как выше написано, установилось всё. Спасибо!
    Но когда зашёл в настройки принтера, далее найти принтер, нашёл драйвера автоматом. При пробной печати выдал ошибку.
    Стоит Rosa Fresh KDE R8 версия KDE4 64-bit.
    Пробовал конеш поставить рекомендуемые от другого принтера не помогло, качал с офф сайта и пробовал через ppd тоже не помогло.
    Файл ошибки оставлю тут — https://cloud.mail.ru/public/BmDc/uNL6jiHY5
    Надеюсь сможем решить проблему=)
    Я просто новичок и не совсем понимаю как тут ещё всё устроено.

    1. mnorin Автор записи

      Спасибо за информацию. Это уже не первый случай с Росой.
      К сожалению, до следующего месяца будет мало времени этим заняться, но я обязательно разберусь, в чем дело, и сделаю новую версию инсталлятора.
      Ошибка заключается в том, что в Росе два простых способа узнать архитектуру системы (32-64 бита) не подходят, потому что кое-чего не хватает, в отличие от других дистрибутивов.
      Надо будет посмотреть, как в этом дистрибутиве узнать архитектуру.
      Можно еще добавиться в скайп (m.norin), помогу установить драйвера (точнее парсер, входящий в установочный пакет) в ручном режиме.

      1. Иван

        Спасибо за ответ. Как будет время обязательно Вам добавлюсь.
        Я заметил что в этой Росе очень трудно с принтерами, еле как установил принтер HP Color LaserJet Pro MFP M117fw и Xerox Phaser 3125. Для НР он сам автоматом установил и не печатал, а утилита НР встроенная зависала и не работала, но всё же через неё получилось установить, а с выше принтером подошли драйвера от модели Phaser 2153.
        А вот третий принтер не хочет работать!=)

        1. Maxim Norin Автор записи

          Обновил инсталлер для драйверов, ссылка на новую версию в статье. Если есть возможность, проверьте, пожалуйста.

  4. Snak

    Добрый день. Manjaro x64. Kyocera 1060DN. При установке выдаёт.
    Do you want to install [y/n]?: y
    Installing…
    cp: не удалось выполнить stat для ‘/tmp/kyosera_ppds/rastertokpsl_unknown’: Нет такого файла или каталога
    Kyosera devices drivers are installed. You may use CUPS now.
    Принтер висит со статусом. Простаивает — Rendering completed. Ничего не печатает.
    На Убунту машинах всё работает.

    1. Maxim Norin Автор записи

      Похоже, не удалось определить архитектуру. Можно посмотреть вывод команды arch и вывод uname -a?

      1. Snak

        arch не знает такую команду.
        uname -a
        Linux Toshiba 4.4.38-1-MANJARO #1 SMP PREEMPT Sat Dec 10 23:03:09 UTC 2016 x86_64 GNU/Linux

  5. Snak

    [snak@Toshiba ~]$ sudo ./kyocera_ppds_installer_1.0.4.sh
    ./kyocera_ppds_installer_1.0.4.sh: строка 5: синтаксическая ошибка рядом с неожиданным маркером «newline»
    ./kyocera_ppds_installer_1.0.4.sh: строка 5: `’

  6. Snak

    [snak@Toshiba ~]$ wget https://github.com/mnorin/kyocera-ppd-installer/blob/master/kyocera_ppds_installer_1.0.4.sh
    —2016-12-24 03:01:05— https://github.com/mnorin/kyocera-ppd-installer/blob/master/kyocera_ppds_installer_1.0.4.sh
    Распознаётся github.com (github.com)… 192.30.253.112, 192.30.253.113
    Подключение к github.com (github.com)|192.30.253.112|:443… соединение установлено.
    HTTP-запрос отправлен. Ожидание ответа… 200 OK
    Длина: нет данных [text/html]
    Сохранение в: «kyocera_ppds_installer_1.0.4.sh»

    kyocera_ppds_instal [ ] 662,77K 816KB/s in 0,8s

    2016-12-24 03:01:06 (816 KB/s) — «kyocera_ppds_installer_1.0.4.sh» сохранён [678679]

    [snak@Toshiba ~]$ chmod +x kyocera_ppds_installer_1.0.4.sh
    [snak@Toshiba ~]$ sudo ./kyocera_ppds_installer_1.0.4.sh
    [sudo] пароль для snak:
    ./kyocera_ppds_installer_1.0.4.sh: строка 5: синтаксическая ошибка рядом с неожиданным маркером «newline»
    ./kyocera_ppds_installer_1.0.4.sh: строка 5: `’
    [snak@Toshiba ~]$

  7. Snak

    [snak@Toshiba ~]$ sudo chmod +x kyocera_ppds_installer_1.0.4.sh
    [sudo] пароль для snak:
    [snak@Toshiba ~]$ sudo ./kyocera_ppds_installer_1.0.4.sh
    ./kyocera_ppds_installer_1.0.4.sh: строка 5: синтаксическая ошибка рядом с неожиданным маркером «newline»
    ./kyocera_ppds_installer_1.0.4.sh: строка 5: `’
    Или так…

      1. Maxim Norin Автор записи

        Хороший вопрос. Никогда не писал )
        Можно сюда в комментариях писать. Интересная ошибка, я такой еще не видел. Сегодня поставлю Manjaro, посмотрю, в чем дело

        1. Snak

          В AURе есть пакет для принтеров kyocera, но 1060DN это региональная версия, и его там нет.:)

    1. Snak

      Полюбилась мне Manjaro. Лёгенько плюс AUR. Здорово заработала, на нетбуке слабеньком, и на ноут поставил не молодой. Обнаружил более новые версие прог, которые через одно место работают на дебиан бэйс системах. Влюбился.:)))

  8. Snak

    обнаружил почти сразу ядро для атомов, 4.4.21 не древнее. Нетбук 6-8 часов работает с ссд, вполне комфортно пользоваться на работе. Никаких перегруженых дженерик ядер, никаких обнов каждый день, всё что работало криво на дебиан бейс, работает ровно. Заметил что некоторые разработчики только в среде аур крутятся. Даже стим не надо с каждым обновлением шаманить сам работает. ХЗ что ещё желать. Чтоб 1060ДН заработал. Но это необходимость. В водянке на большом компе сдохла помпа, новая пока в техасе гдето трётся, к февралю приедет наверно. А работать надо.:)))

    1. Maxim Norin Автор записи

      Мне, наверное, везло с Debian’ом. Бывало, конечно, приходилось под новое железо собирать свежее ядро из исходников, но со временем менял на пакетное. Нетбук под Jessie сейчас работает вполне прилично, правда, я систему потюнил немного, повыкидывал всё ненужное. Lenovo S10-2 на Атоме N270, кстати говоря, тоже на SSD ) Со свежей батарейкой тоже 6-8 часов. Правда, я на Дебиане с 2005 года, с версии 3.0, помню как обновлял на 3.1 «Sarge». И потом пару раз ставил 2.2 («Potato» вроде, последний раз ставил его на Пентиум 100 MHz с 16 Мб оперативки в 2011 году, когда более новые версии не вставали, потому что оперативки инсталлеру не хватало). Плюс для развития собирал как-то LFS. И Генту без хэндбука с третьего раза, давно правда. Опять же, в Дебиане всё можно при желании из сырцов собрать, в testing ветке софт посвежее. Manjaro я бы с удовольствием на настоящее железо поставил, но пока не на что.

  9. Snak

    Максим, полный кат команд выкладывал, использовал get.

    [snak@Toshiba ~]$ wget https://github.com/mnorin/kyocera-ppd-installer/blob/master/kyocera_ppds_installer_1.0.4.sh
    —2016-12-24 03:01:05— https://github.com/mnorin/kyocera-ppd-installer/blob/master/kyocera_ppds_installer_1.0.4.sh
    Распознаётся github.com (github.com)… 192.30.253.112, 192.30.253.113
    Подключение к github.com (github.com)|192.30.253.112|:443… соединение установлено.
    HTTP-запрос отправлен. Ожидание ответа… 200 OK
    Длина: нет данных [text/html]
    Сохранение в: «kyocera_ppds_installer_1.0.4.sh»

    kyocera_ppds_instal [ ] 662,77K 816KB/s in 0,8s

    2016-12-24 03:01:06 (816 KB/s) — «kyocera_ppds_installer_1.0.4.sh» сохранён [678679]

    [snak@Toshiba ~]$ chmod +x kyocera_ppds_installer_1.0.4.sh
    [snak@Toshiba ~]$ sudo ./kyocera_ppds_installer_1.0.4.sh
    [sudo] пароль для snak:
    ./kyocera_ppds_installer_1.0.4.sh: строка 5: синтаксическая ошибка рядом с неожиданным маркером «newline»
    ./kyocera_ppds_installer_1.0.4.sh: строка 5: `’
    [snak@Toshiba ~]$

    1. Maxim Norin Автор записи

      Тут проблема не в скачивании, а в выполнении. Но на всякий случай я запланировал какую-нибудь контрольную сумму уже встроить в скрипт.

      1. Snak

        я не эксперт, но в 5 строке скрипта, устаревший или слишком новый синтаксис. Сталкивался с таким при настройке conky.

      1. Snak

        Работает, спасибо большое. Поправь шапку… Пиши в почту если хочется пообщаться…

  10. Snak

    Дебиан слишком пропитан Деброй. Много действий. Мне манжарик дегче показался, плюс тру линукс вэй.Не пакетные обновы, тоже плюс как по мне. зайти с паролем один раз в пару недель лучше, чем каждый день и иногда не один. опера и манжарик с ядром под атомы, мне нравится. перепробывал все браузеры линукс остановился на опере. Ну кроме извратских консольных…

    1. Maxim Norin Автор записи

      Я ничего не менял, посмотри, что внутри. Файл должен быть порядка 172 килобайт, если размер 678679, то это не скрипт

      1. Snak

        всё заработало, для начинающих наверно первое с wget. не все шаристые бойцы чтоб с гитхаба чтото скачать, а скачав не поймут как ставится…

  11. Snak

    Что мне гоорит version в фигурных скбках работать не будет, мне то всё равно но начающие растроится могут.:)

    1. Maxim Norin Автор записи

      Вот же дотошный человек )
      Я уже придумал, как без версии обойтись. Сегодня, чуть попозже, сделаю

  12. Snak

    Я исключительно во благо человечества. Вдруг забыл, не доглядел. Я подскажу. Ничего такого.:)

    1. Maxim Norin Автор записи

      Готово. Теперь есть просто ссылка, без версии, по которой будет скачиваться последняя версия скрипта.

    1. Maxim Norin Автор записи

      Даже не знаю, чем вам помочь. Чтобы как-то решить проблему, надо хоть что-то. Кусочек лога CUPS, хоть какую-то информацию.
      Плюс такого принтера у меня нет уже больше года, вряд ли смогу проверить печать на А5.

  13. Геннадий

    на Ubuntu 17
    вылезает вот такое
    Installer by Maxim Norin (https://mnorin.com, Mail: mnorin@mnorin.com).
    Wrapper by tr0n (sorry, don’t have contact)

    kyocera_ppds_installer.sh: 2261: [: unexpected operator
    Do you want to install [y/n]?: kyocera_ppds_installer.sh: 2270: read: Illegal option -n

    1. Maxim Norin Автор записи

      Спасибо за информацию. К сожалению, нет под рукой Ubuntu 17 в данный момент, поэтому быстро не проверю.

  14. Максим

    Подскажите на Linux of5 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u3 (2017-08-06) x86_64 GNU/Linux
    не печатает kyosera FS-1060dn файл отправляю на печать в cups работа печати завершается, а сам он не печатает. Что можно сделать,

  15. Максим

    Принтер Куосера FS-1060 не выводит на печать хотя в cups печать завершена

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *